Java Debugger says, that i have problem with java version

After build attempt, java debugger extension pack returns:

enter image description here

My Java environment:

enter image description here

My settings:

enter image description here

If i press Proceed, application programm works correctly.
There some few java versions, but i’m already added PATH and JAVA_HOME.

enter image description here

How can i disable that problems from Java Debugger Extension in VSCode?

1
Leave a Reply

avatar
1 Comment threads
0 Thread replies
0 Followers
 
Most reacted comment
Hottest comment thread
1 Comment authors
Jason Recent comment authors
  Subscribe  
newest oldest most voted
Notify of
Jason
Guest

try to change the extension generated file .settings/org.eclipse.jdt.core.prefs like :

eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.problem.forbiddenReference=warning
org.eclipse.jdt.core.compiler.source=1.8